Times shown on the patient queue and nurse screen pages are behind by 1 hour
Incident Report for Experity Queuing & eRegistration
Resolved
This incident has been resolved. The correct times should now appear on the patient queue and nurse screen.
Posted Mar 10, 2019 - 10:21 EDT
Investigating
Times shown on the patient queue and nurse screen are behind by 1 hour since daylight savings time began this morning. We've identified the cause and will post an update when the issue is resolved.
Posted Mar 10, 2019 - 08:49 EDT
This incident affected: Queuing & eRegistration (Web Site).