Issues opening patient demographics modal
Incident Report for Experity Queuing & eRegistration
Resolved
We've determined the issue to be related to a website update and have rolled back the change for further testing. Demographics modals should now be working properly again.
Posted Jun 12, 2019 - 08:46 EDT
Investigating
We're currently getting reports that the patient demographics modal is no longer opening. We're investigating potential causes now.
Posted Jun 12, 2019 - 08:36 EDT
This incident affected: Queuing & eRegistration (Web Site).