Future Patients Page
Incident Report for Experity Queuing & eRegistration
Resolved
This incident has been resolved.
Posted Nov 09, 2022 - 15:50 EST
Investigating
We are aware the Future Patients Page is not loading. Our teams are working as quickly as possible to identify the root cause.
Status updates will be provided. We understand the impact this may cause and appreciate your patience.
Posted Nov 09, 2022 - 15:17 EST
This incident affected: Queuing & eRegistration (Web Site, API).