DocuTAP Integration Issues
Incident Report for Clockwise MD
Resolved
This incident has been resolved.
Posted 9 months ago. Oct 08, 2018 - 23:59 EDT
Investigating
Clinics integrated with DocuTAP may be experiencing long delays in patients moving from Clockwise to DocuTAP. We are working with our vendor partners to address the issue and will update this incident when more information is available.
Posted 9 months ago. Oct 08, 2018 - 11:44 EDT
This incident affected: EHR Integration Engine.